JQuery address picker rails gem breaks with JQuery 1.9.x

Note to self:

If you're going to use address_picker_rails (0.2.1), make sure your jquery-rails gem is set to <= 2.1.3. Apparently Jquery-UI 1.9.1 breaks address_picker_rails and jquery-rails 2.2.0, uses the 1.9.x branch.

I hope this will save you some time debugging address_picker_rails if you’ve accidentally updated your jquery-rails gem to the latest version, only to find out your address autocomplete function no longer allowing you to select the results.

Many thanks to this StackOverflow question which led me to suspect that it wasn’t a address_picker_rails bug but rather a version compatibility issue with jquery-ui.js.